Related eBooks

I am trying to compile oclvanitygen because I have an Nvidia GTX 1080 that would most likely be helpful for this. I’m using the Windows Subsystem for Linux with Ubuntu 18.04.

I tried this command: gcc oclvanitygen.o oclengine.o pattern.o util.o -o oclvanitygen -ggdb -O3 -Wall -L/usr/lib/x86_64-linux-gnu/ -lpcre -lcrypto -lm -lpthread -l:/usr/lib/x86_64-linux-gnu/libopencl.so.1

It basically says that libopencl.so.1 does not exist. However, I have libnvidia-opencl.so.1, so I try this command: gcc oclvanitygen.o oclengine.o pattern.o util.o -o oclvanitygen -ggdb -O3 -Wall -L/usr/lib/x86_64-linux-gnu/ -lpcre -lcrypto -lm -lpthread -l:/usr/lib/x86_64-linux-gnu/libnvidia-opencl.so.1

Then it says /usr/bin/ld: cannot find -l:/usr/lib/x86_64-linux-gnu/libnvidia-opencl.so.1

So I do a list of x86_64-linux-gnu, and there it is, clear as day. list of x86-64-linux-gnu

How can I compile this correctly? Here is a picture of what happens when I run the command: GCC Command

I have installed the ocl-icd-opencl-dev package, but it does not include libopencl.so.1.

Please tell me if I am doing something wrong. Thanks!

source

By pplny

답글 남기기

이메일 주소는 공개되지 않습니다. 필수 필드는 *로 표시됩니다

Translate »